#newsgrabber 2018-02-22,Thu

Logs of this channel are not protected. You can protect them by a password.

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)


WhoWhatWhen
***octothorp has joined #newsgrabber [00:03]
................................................. (idle for 4h1mn)
Jens has quit IRC (Remote host closed the connection)
Jens has joined #newsgrabber
[04:04]
....... (idle for 34mn)
qw3rty119 has joined #newsgrabber [04:39]
qw3rty118 has quit IRC (Ping timeout: 600 seconds) [04:44]
..................................................................................... (idle for 7h2mn)
JAAfind_executable seems to work. The output of python -V had the same format "Python 5.6.7" since at least version 2.3 (didn't bother to check even older ones), so my code checks whether the output matches '^Python 2\.'. It tries python and python2. This should make it work on all reasonable systems.
I can't push the code right now, will do that later when I'm home.
[11:46]
.............................................................................. (idle for 6h25mn)
jrwrSo kaz, I see you fought with the bot :P and lost
:P
[18:11]
................... (idle for 1h30mn)
***GitHub38 has joined #newsgrabber [19:41]
GitHub38[13NewsGrabber-Warrior] 15JustAnotherArchivist opened pull request #13: Find Python 2 dynamically (06master...06master) 02https://git.io/vAgMk [19:41]
***GitHub38 has left [19:41]
JAAKaz, Smiley, Aoede: ^ [19:41]
***GitHub53 has joined #newsgrabber [19:42]
GitHub53[13NewsGrabber-Warrior] 15kurtmclester closed pull request #13: Find Python 2 dynamically (06master...06master) 02https://git.io/vAgMk [19:42]
***GitHub53 has left
GitHub178 has joined #newsgrabber
[19:42]
GitHub178[13NewsGrabber-Warrior] 15kurtmclester pushed 2 new commits to 06master: 02https://git.io/vAgMY
13NewsGrabber-Warrior/06master 1405cf256 15JustAnotherArchivist: Find Python 2 dynamically...
13NewsGrabber-Warrior/06master 140c2d93f 15kurtmclester: Merge pull request #13 from JustAnotherArchivist/master...
[19:42]
***GitHub178 has left
GitHub69 has joined #newsgrabber
[19:42]
GitHub69[13NewsGrabber-Warrior] 15kurtmclester pushed 1 new commit to 06master: 02https://git.io/vAgM3
13NewsGrabber-Warrior/06master 14731f176 15kurtmclester: Bump version
[19:42]
***GitHub69 has left [19:42]
Kazthanks! [19:42]
JAAOh right, forgot the version.
Does it work?
[19:44]
Kazjust waiting for my vm to boot up [19:49]
warrior is failing to boot now.. [20:03]
JAA:-| I hope that's unrelated. [20:03]
Kazseems to be, it's not even getting past the whole 'updating warrior code' step [20:04]
Smileyyou borked it?
omg it works \o/
21014574 100% 191.01kB/s 0:01:47 (xfer#1, to-check=0/1)
[20:06]
Kazi wonder if warrior2 finally aged out..
error: gnutls_handshake() failed: A TLS fatal alert has been received.
I don't have the config on hand to import the ovf into esxi so can't test a fresh install
[20:11]
jrwrit did
its got super old openssl on it
[20:13]
Smileylol [20:15]
JAAYeah, can't do TLS1.1 even IIRC. [20:17]
***newsbuddy has joined #newsgrabber [20:17]
newsbuddyHello! I've just been (re)started. Follow my newsgrabs in #newsgrabberbot [20:17]
jrwrthats why I pushed for the docker-warrior to become defacto [20:19]
Kazhttps://githubengineering.com/crypto-removal-notice/
February 22, 2018 19:00 UTC (11:00 am PST): Permanently disable deprecated algorithms
an HOUR ago
[20:23]
***Kaz changes topic to: https://github.com/ArchiveTeam/NewsGrabber-Warrior // Warrior is no longer supported in any form [20:24]
jrwrWell shit
we need to take warrior2 out back and shoot it then
[20:25]
Kazwe do. [20:25]
jrwrand update newsgrabber for v3 [20:26]
Kazthat too
full newsgrabber rewrite, anyone?
[20:26]
jrwrmostly
update wpull
[20:26]
Kazi'm sure there's some reason we're locked to 1.2.3 though [20:26]
jrwrrebase 1.2.3 to work with newer versions of python or something
ya
its the most stable
[20:26]
Kazah [20:26]
jrwrthere is not a whole ton of programmers who want to approach this issue
maybe a Call to arms to get wpull stable, I know arkiver is our cod hero when it comes to pipelines
code*
[20:27]
JAAOuch [20:41]
Smileywhy not just get python2 installed in warrior2 alongside python3? [20:44]
JAAThat doesn't help with the TLS problems...
We had problems with that before, by the way, when we were archiving Imzy.
So *if* we wanted to keep that ancient warrior around, we'd have to update OpenSSL. I don't want to have to do that though.
[20:45]
jrwrits doable with some custom packages and scripts
but its going to be a PITA
we just need to start porting things to warrior3
[20:49]
JAAYeah
What's the problem with warrior 3?
[20:50]
SmileyJAA: it doesn't have python2 i think [20:52]
JAAWell, in that case, time to port our stuff to Python 3. [20:53]
jrwrno it does
and ip
[20:54]
JAAThough I'm surprised to hear that there is an OS without Py2. [20:54]
jrwrpip*
its just much newer
[20:54]
JAAAh right.
Well, porting to Python 3 would still be a good idea.
[20:54]
jrwrYa since 2.7 is about to be killed outright
in a few years
[20:55]
JAAIt's about time.
Python 3 is almost 10 years old now...
[20:56]
Smileynewsgrabber wasn't originally a warrior project
so i don't think the code was very weel l thought out in that reguard
[21:01]
...... (idle for 26mn)
JAAjrwr: So, what is the issue with warrior3? It being newer shouldn't be a problem, right? I've been running the scripts for most projects (except the Python 2 only, i.e. Flickr, Vidme, and Newsgrabber) on current Debian machines without any issues.
I mean, apart from getting people to replace their warrior 2 instances.
[21:27]
jrwrnone, most pipelines will work, its mostly just getting people to upgrade [21:28]
JAAI see. [21:28]
jrwrwpull based ones get wonky on 3 [21:28]
JAAHmm [21:28]
jrwrmostly since its well.. a wonky project [21:28]
JAAFor the upgrading part, if there is any way to detect warrior 2 vs. 3 on the tracker side, we could return a 403 error or something, which should appear on the dashboard I think?
Yeah, I've been working on wpull quite actively.
[21:29]
jrwrya, there are ways [21:29]
JAAI've implemented a few new things and fixed several bugs. [21:29]
jrwrVery nice [21:29]
JAAThat's 2.x though.
I have no intention of working with 1.x.
I was planning to push my updated 2.x code today anyway.
[21:29]
jrwrI wonder if newsgrabber can be modded to use the new version
give it a test drive
[21:30]
JAAI'm sure that can be done.
I don't consider 2.x stable yet though. Lots of more bug fixes are in order.
But yeah, I'm the first person to work on that code since almost a year (when FalconK implemented some workarounds for the nastiest crashes).
[21:33]
jrwrDo you have a paypal, I want to throw money at you [21:35]
JAANo need. Throw it at IA, EFF, etc. or into infrastructure instead. :-) [21:44]
jrwrjrwr throws it at IA [21:44]

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)